import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "TIMING ADVANCE.+(\\d+)";
final String string = "Printout:\n"
+ "LOADING PROGRAM VERSION 24.103-0\n"
+ "PAGING IMSI ............................. 216990100000015\n"
+ "MANUAL PAGING ........................ SUCCESSFUL\n"
+ "IMSI ................................. 216990100000015 \n"
+ "TMSI ................................. 0063E557H/0006546775D\n"
+ "IMEI ................................. 355359049230050 WHITE LIST \n"
+ "IMEISV ............................... 57\n"
+ "MSISDN ............................... 36034031015 \n"
+ "CMSISDN .............................. N \n"
+ "SUBS STATUS .......................... IDLE\n"
+ "MOBILE COUNTRY CODE .................. 0216D\n"
+ "MOBILE NETWORK CODE .................. 0003D\n"
+ "LOCATION AREA CODE OF IMSI ........... 0D49H/03401D\n"
+ "CELL ID .............................. 84D1H/34001D\n"
+ "PAGING INTERFACE ..................... GSM\n"
+ "PAGING TIME .......................... 10 \n"
+ "TIMING ADVANCE ....................... 0\n"
+ "COMMAND EXECUTED";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}