const regex = new RegExp('TIMING ADVANCE.+(\\d+)', '')
const str = `Printout:
LOADING PROGRAM VERSION 24.103-0
PAGING IMSI ............................. 216990100000015
MANUAL PAGING ........................ SUCCESSFUL
IMSI ................................. 216990100000015
TMSI ................................. 0063E557H/0006546775D
IMEI ................................. 355359049230050 WHITE LIST
IMEISV ............................... 57
MSISDN ............................... 36034031015
CMSISDN .............................. N
SUBS STATUS .......................... IDLE
MOBILE COUNTRY CODE .................. 0216D
MOBILE NETWORK CODE .................. 0003D
LOCATION AREA CODE OF IMSI ........... 0D49H/03401D
CELL ID .............................. 84D1H/34001D
PAGING INTERFACE ..................... GSM
PAGING TIME .......................... 10
TIMING ADVANCE ....................... 0
COMMAND EXECUTED`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}