import Foundation
let pattern = #"TIMING ADVANCE.+(\d+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Printout:
LOADING PROGRAM VERSION 24.103-0
PAGING IMSI ............................. 216990100000015
MANUAL PAGING ........................ SUCCESSFUL
IMSI ................................. 216990100000015
TMSI ................................. 0063E557H/0006546775D
IMEI ................................. 355359049230050 WHITE LIST
IMEISV ............................... 57
MSISDN ............................... 36034031015
CMSISDN .............................. N
SUBS STATUS .......................... IDLE
MOBILE COUNTRY CODE .................. 0216D
MOBILE NETWORK CODE .................. 0003D
LOCATION AREA CODE OF IMSI ........... 0D49H/03401D
CELL ID .............................. 84D1H/34001D
PAGING INTERFACE ..................... GSM
PAGING TIME .......................... 10
TIMING ADVANCE ....................... 0
COMMAND EXECUTED
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}