# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"TIMING ADVANCE.+(\d+)"
test_str = ("Printout:\n"
"LOADING PROGRAM VERSION 24.103-0\n"
"PAGING IMSI ............................. 216990100000015\n"
"MANUAL PAGING ........................ SUCCESSFUL\n"
"IMSI ................................. 216990100000015 \n"
"TMSI ................................. 0063E557H/0006546775D\n"
"IMEI ................................. 355359049230050 WHITE LIST \n"
"IMEISV ............................... 57\n"
"MSISDN ............................... 36034031015 \n"
"CMSISDN .............................. N \n"
"SUBS STATUS .......................... IDLE\n"
"MOBILE COUNTRY CODE .................. 0216D\n"
"MOBILE NETWORK CODE .................. 0003D\n"
"LOCATION AREA CODE OF IMSI ........... 0D49H/03401D\n"
"CELL ID .............................. 84D1H/34001D\n"
"PAGING INTERFACE ..................... GSM\n"
"PAGING TIME .......................... 10 \n"
"TIMING ADVANCE ....................... 0\n"
"COMMAND EXECUTED")
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.