re = /TIMING ADVANCE.+(\d+)/
str = 'Printout:
LOADING PROGRAM VERSION 24.103-0
PAGING IMSI ............................. 216990100000015
MANUAL PAGING ........................ SUCCESSFUL
IMSI ................................. 216990100000015
TMSI ................................. 0063E557H/0006546775D
IMEI ................................. 355359049230050 WHITE LIST
IMEISV ............................... 57
MSISDN ............................... 36034031015
CMSISDN .............................. N
SUBS STATUS .......................... IDLE
MOBILE COUNTRY CODE .................. 0216D
MOBILE NETWORK CODE .................. 0003D
LOCATION AREA CODE OF IMSI ........... 0D49H/03401D
CELL ID .............................. 84D1H/34001D
PAGING INTERFACE ..................... GSM
PAGING TIME .......................... 10
TIMING ADVANCE ....................... 0
COMMAND EXECUTED'
# Print the match result
str.match(re) do |match|
puts match.to_s
end