#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^(((-?\d*(,\d+)?\*?)|\d+\/\d+)?(x(\^-?\d+)?)?)((\+|-)(((-?\d*(,\d+)?\*?)|\d+\/\d+)?(x(\^-?\d+)?)?))*$"
Local $sString = "x^11-3x^9+12x^7+57/23x^6-6x^5+x^4-11*x^3+x^2-x-33" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")