import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(((-?\\d*(,\\d+)?\\*?)|\\d+\\/\\d+)?(x(\\^-?\\d+)?)?)((\\+|-)(((-?\\d*(,\\d+)?\\*?)|\\d+\\/\\d+)?(x(\\^-?\\d+)?)?))*$";
final String string = "x^11-3x^9+12x^7+57/23x^6-6x^5+x^4-11*x^3+x^2-x-33\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}