package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(((-?\d*(,\d+)?\*?)|\d+\/\d+)?(x(\^-?\d+)?)?)((\+|-)(((-?\d*(,\d+)?\*?)|\d+\/\d+)?(x(\^-?\d+)?)?))*$`)
var str = `x^11-3x^9+12x^7+57/23x^6-6x^5+x^4-11*x^3+x^2-x-33
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}