const regex = /^(((-?\d*(,\d+)?\*?)|\d+\/\d+)?(x(\^-?\d+)?)?)((\+|-)(((-?\d*(,\d+)?\*?)|\d+\/\d+)?(x(\^-?\d+)?)?))*$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(((-?\\d*(,\\d+)?\\*?)|\\d+\\\/\\d+)?(x(\\^-?\\d+)?)?)((\\+|-)(((-?\\d*(,\\d+)?\\*?)|\\d+\\\/\\d+)?(x(\\^-?\\d+)?)?))*$', '')
const str = `x^11-3x^9+12x^7+57/23x^6-6x^5+x^4-11*x^3+x^2-x-33
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}