using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((([A-Z][a-z]*(\s))([a-z]*(\s))*[a-z]*[.])(\s)*)*(?!([A-z0-9]*(\s)))";
string input = @"Theqwererwerwewe qwe ertret asdf. The wer. The awerwe. The we. The wewe. The awe. ";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}