$re = '/((([A-Z][a-z]*(\s))([a-z]*(\s))*[a-z]*[.])(\s)*)*(?!([A-z0-9]*(\s)))/';
$str = 'Theqwererwerwewe qwe ertret asdf. The wer. The awerwe. The we. The wewe. The awe. ';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);