const regex = /((([A-Z][a-z]*(\s))([a-z]*(\s))*[a-z]*[.])(\s)*)*(?!([A-z0-9]*(\s)))/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((([A-Z][a-z]*(\\s))([a-z]*(\\s))*[a-z]*[.])(\\s)*)*(?!([A-z0-9]*(\\s)))', '')
const str = `Theqwererwerwewe qwe ertret asdf. The wer. The awerwe. The we. The wewe. The awe. `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}