import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((([A-Z][a-z]*(\\s))([a-z]*(\\s))*[a-z]*[.])(\\s)*)*(?!([A-z0-9]*(\\s)))";
final String string = "Theqwererwerwewe qwe ertret asdf. The wer. The awerwe. The we. The wewe. The awe. ";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}