import re
regex = re.compile(r"<ChA([0-9])\*ChB([0-9])>\*<(.*?)>\*<(.*?)>\*<(.*?)>\*<(.*?)>\*<(.*?)>\n")
test_str = ("<ChA1*ChB4>*<stopped>*<internal>*<70047272>*<00:00:00>*<00:00:00>\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")