// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"<ChA([0-9])\*ChB([0-9])>\*<(.*?)>\*<(.*?)>\*<(.*?)>\*<(.*?)>\*<(.*?)>\n").unwrap();
let string = "<ChA1*ChB4>*<stopped>*<internal>*<70047272>*<00:00:00>*<00:00:00>
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}