#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[-+]?[0-9]*\.?[0-9]+$"
Local $sString = "1" & @CRLF & _
"2.1" & @CRLF & _
"3.14" & @CRLF & _
"-4" & @CRLF & _
"+5" & @CRLF & _
".6" & @CRLF & _
"-.7" & @CRLF & _
"+.8" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"." & @CRLF & _
"-" & @CRLF & _
"+" & @CRLF & _
"-." & @CRLF & _
"+." & @CRLF & _
"9." & @CRLF & _
"10..1" & @CRLF & _
"11.1.2" & @CRLF & _
".12.1" & @CRLF & _
"..13" & @CRLF & _
"-.14." & @CRLF & _
"+..15"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")