import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[-+]?[0-9]*\\.?[0-9]+$";
final String string = "1\n"
+ "2.1\n"
+ "3.14\n"
+ "-4\n"
+ "+5\n"
+ ".6\n"
+ "-.7\n"
+ "+.8\n\n\n"
+ ".\n"
+ "-\n"
+ "+\n"
+ "-.\n"
+ "+.\n"
+ "9.\n"
+ "10..1\n"
+ "11.1.2\n"
+ ".12.1\n"
+ "..13\n"
+ "-.14.\n"
+ "+..15";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}