# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^[-+]?[0-9]*\.?[0-9]+$"
test_str = ("1\n"
"2.1\n"
"3.14\n"
"-4\n"
"+5\n"
".6\n"
"-.7\n"
"+.8\n\n\n"
".\n"
"-\n"
"+\n"
"-.\n"
"+.\n"
"9.\n"
"10..1\n"
"11.1.2\n"
".12.1\n"
"..13\n"
"-.14.\n"
"+..15")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.