re = /^[-+]?[0-9]*\.?[0-9]+$/m
str = '1
2.1
3.14
-4
+5
.6
-.7
+.8
.
-
+
-.
+.
9.
10..1
11.1.2
.12.1
..13
-.14.
+..15'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end