package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[-+]?[0-9]*\.?[0-9]+$`)
var str = `1
2.1
3.14
-4
+5
.6
-.7
+.8
.
-
+
-.
+.
9.
10..1
11.1.2
.12.1
..13
-.14.
+..15`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}