#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:(?:0?[0-9]|1[0-2]):[0-5]\d)$"
Local $sString = "08:00" & @CRLF & _
"01:15" & @CRLF & _
"1:14" & @CRLF & _
"02:23" & @CRLF & _
"23:23" & @CRLF & _
"12:01" & @CRLF & _
"13:05" & @CRLF & _
"3:04" & @CRLF & _
"5:65" & @CRLF & _
"0:0" & @CRLF & _
"12:9" & @CRLF & _
"0:34" & @CRLF & _
"0:01" & @CRLF & _
"00:31" & @CRLF & _
"0:00" & @CRLF & _
"00:00" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")