const regex = /^(?:(?:0?[0-9]|1[0-2]):[0-5]\d)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:(?:0?[0-9]|1[0-2]):[0-5]\\d)$', 'gm')
const str = `08:00
01:15
1:14
02:23
23:23
12:01
13:05
3:04
5:65
0:0
12:9
0:34
0:01
00:31
0:00
00:00
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}