use strict;
my $str = '08:00
01:15
1:14
02:23
23:23
12:01
13:05
3:04
5:65
0:0
12:9
0:34
0:01
00:31
0:00
00:00
';
my $regex = qr/^(?:(?:0?[0-9]|1[0-2]):[0-5]\d)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}