$re = '/^(?:(?:0?[0-9]|1[0-2]):[0-5]\d)$/m';
$str = '08:00
01:15
1:14
02:23
23:23
12:01
13:05
3:04
5:65
0:0
12:9
0:34
0:01
00:31
0:00
00:00
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);