// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:(?:0?[0-9]|1[0-2]):[0-5]\d)$").unwrap();
let string = "08:00
01:15
1:14
02:23
23:23
12:01
13:05
3:04
5:65
0:0
12:9
0:34
0:01
00:31
0:00
00:00
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}