using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\d*[^\d]?){0,3}\d*$";
string input = @"56 + 33
56 + 33 + 6
Error
1234
123987ss123123 131x23897
9823428394f88998 8788x8787";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}