// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(\d*[^\d]?){0,3}\d*$").unwrap();
let string = "56 + 33
56 + 33 + 6
Error
1234
123987ss123123 131x23897
9823428394f88998 8788x8787";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}