$re = '/^(\d*[^\d]?){0,3}\d*$/m';
$str = '56 + 33
56 + 33 + 6
Error
1234
123987ss123123 131x23897
9823428394f88998 8788x8787';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);