import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\d*[^\\d]?){0,3}\\d*$";
final String string = "56 + 33\n"
+ "56 + 33 + 6\n"
+ "Error\n"
+ "1234\n"
+ "123987ss123123 131x23897\n"
+ "9823428394f88998 8788x8787";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}