import re
regex = re.compile(r"^(\d*[^\d]?){0,3}\d*$", flags=re.MULTILINE)
test_str = ("56 + 33\n"
"56 + 33 + 6\n"
"Error\n"
"1234\n"
"123987ss123123 131x23897\n"
"9823428394f88998 8788x8787")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")