using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\+971\s[0-9]{3}-[0-9]{6}";
string input = @"+971 556-123456
+996 556-123456
+971 556-123896
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}