package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\+971\s[0-9]{3}-[0-9]{6}`)
var str = `+971 556-123456
+996 556-123456
+971 556-123896
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}