$re = '/\+971\s[0-9]{3}-[0-9]{6}/';
$str = '+971 556-123456
+996 556-123456
+971 556-123896
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);