// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\+971\s[0-9]{3}-[0-9]{6}").unwrap();
let string = "+971 556-123456
+996 556-123456
+971 556-123896
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}