#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)^Group \d+$(?:.(?!^$))*?test.*?(?:^$|\Z)"
Local $sString = "Group 1" & @CRLF & _
"adfdf" & @CRLF & _
"dd test ddfdf" & @CRLF & _
"dfdfadf" & @CRLF & _
"" & @CRLF & _
"Group 2" & @CRLF & _
"ddfadfa" & @CRLF & _
"" & @CRLF & _
"Group 3" & @CRLF & _
"add test " & @CRLF & _
"adfdff" & @CRLF & _
"" & @CRLF & _
"Group 4" & @CRLF & _
"adfdf" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Group 3" & @CRLF & _
"add test " & @CRLF & _
"adfdff" & @CRLF & _
"" & @CRLF & _
"Group 3" & @CRLF & _
"add test " & @CRLF & _
"adfdff" & @CRLF & _
"" & @CRLF & _
"Group 4" & @CRLF & _
"adfdf" & @CRLF & _
"Group 4" & @CRLF & _
"adfdf" & @CRLF & _
"" & @CRLF & _
"Group 3" & @CRLF & _
"add test " & @CRLF & _
"adfdff"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")