using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^Group \d+$(?:.(?!^$))*?test.*?(?:^$|\Z)";
string input = @"Group 1
adfdf
dd test ddfdf
dfdfadf
Group 2
ddfadfa
Group 3
add test
adfdff
Group 4
adfdf
Group 3
add test
adfdff
Group 3
add test
adfdff
Group 4
adfdf
Group 4
adfdf
Group 3
add test
adfdff";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}