const regex = /^Group \d+$(?:.(?!^$))*?test.*?(?:^$|\Z)/gms;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^Group \\d+$(?:.(?!^$))*?test.*?(?:^$|\\Z)', 'gms')
const str = `Group 1
adfdf
dd test ddfdf
dfdfadf
Group 2
ddfadfa
Group 3
add test
adfdff
Group 4
adfdf
Group 3
add test
adfdff
Group 3
add test
adfdff
Group 4
adfdf
Group 4
adfdf
Group 3
add test
adfdff`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}