$re = '/^Group \d+$(?:.(?!^$))*?test.*?(?:^$|\Z)/ms';
$str = 'Group 1
adfdf
dd test ddfdf
dfdfadf
Group 2
ddfadfa
Group 3
add test
adfdff
Group 4
adfdf
Group 3
add test
adfdff
Group 3
add test
adfdff
Group 4
adfdf
Group 4
adfdf
Group 3
add test
adfdff';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);