re = /^Group \d+$(?:.(?!^$))*?test.*?(?:^$|\Z)/m
str = 'Group 1
adfdf
dd test ddfdf
dfdfadf
Group 2
ddfadfa
Group 3
add test
adfdff
Group 4
adfdf
Group 3
add test
adfdff
Group 3
add test
adfdff
Group 4
adfdf
Group 4
adfdf
Group 3
add test
adfdff'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end