# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^.*?@[^ ]+|^.*$//gm;t' <<< " Organization 2
info@something.org.au more@something.com market@gmail.com single@noidea.com human@myplace.com south@north.com darlings@mall.com
Organization 3
headmistress@money.com head@skull.com "