$re = '/^.*?@[^ ]+|^.*$/m';
$str = ' Organization 2
info@something.org.au more@something.com market@gmail.com single@noidea.com human@myplace.com south@north.com darlings@mall.com
Organization 3
headmistress@money.com head@skull.com ';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;