package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^.*?@[^ ]+|^.*$`)
var str = ` Organization 2
info@something.org.au more@something.com market@gmail.com single@noidea.com human@myplace.com south@north.com darlings@mall.com
Organization 3
headmistress@money.com head@skull.com `
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}