#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^.*?@[^ ]+|^.*$"
Local $sString = " Organization 2" & @CRLF & _
"" & @CRLF & _
" info@something.org.au more@something.com market@gmail.com single@noidea.com human@myplace.com south@north.com darlings@mall.com " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" Organization 3" & @CRLF & _
"" & @CRLF & _
" headmistress@money.com head@skull.com "
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)