use strict;
my $str = ' Organization 2
info@something.org.au more@something.com market@gmail.com single@noidea.com human@myplace.com south@north.com darlings@mall.com
Organization 3
headmistress@money.com head@skull.com ';
my $regex = qr/^.*?@[^ ]+|^.*$/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";