# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(?:[^\\/]+\\/)?([a-zA-Z]+(?:-[a-zA-Z]+)+).*$/\1/gm;t' <<< "something-something-something/45436534/pd
something-something-something-something/86787097/pd
1135/something-something-something-86789/pp
1125/something-something-something-something-86749/pp"