using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:[^\/]+\/)?([a-zA-Z]+(?:-[a-zA-Z]+)+).*$";
string substitution = @"\1";
string input = @"something-something-something/45436534/pd
something-something-something-something/86787097/pd
1135/something-something-something-86789/pp
1125/something-something-something-something-86749/pp";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}