#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(?:[^\/]+\/)?([a-zA-Z]+(?:-[a-zA-Z]+)+).*$"
Local $sString = "something-something-something/45436534/pd" & @CRLF & _
"something-something-something-something/86787097/pd" & @CRLF & _
"1135/something-something-something-86789/pp" & @CRLF & _
"1125/something-something-something-something-86749/pp"
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)