re = /^(?:[^\/]+\/)?([a-zA-Z]+(?:-[a-zA-Z]+)+).*$/m
str = 'something-something-something/45436534/pd
something-something-something-something/86787097/pd
1135/something-something-something-86789/pp
1125/something-something-something-something-86749/pp'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result