import re
regex = re.compile(r"^(?:[^\/]+\/)?([a-zA-Z]+(?:-[a-zA-Z]+)+).*$", flags=re.MULTILINE)
test_str = ("something-something-something/45436534/pd\n"
"something-something-something-something/86787097/pd\n"
"1135/something-something-something-86789/pp\n"
"1125/something-something-something-something-86749/pp")
subst = "\\1"
result = regex.sub(subst, test_str)
if result:
print(result)