import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\{1:.*\\{2:.*\\{3:.*\\{4:.*";
final String string = "{1:F21CITICCIMMBL0107000001}{2:O2991405210107CITILUL0MBL01070000012101071405N}{3:{108:0000000000000114}}{4:\n"
+ ":20:401648471\n"
+ ":21:FT-TRN1234567890\n"
+ ":79:/ACK/Response Code 200\n"
+ "SCAR Response\n"
+ "Received\n"
+ "}\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}